R-Group Decomposition not removing At-H fragments

Hi,

When I apply the decomposition there still remains [H]-At molecules even with option “Remove hydrogen only R-groups’. This option doesn’t seem to be working.

The box ‘Remove hydrogen only R-groups’ is checked.

Further, I’m unable to figure out how to use the same node to decompose at designated positions. Can someone help upload an example on how to label the scaffold to enable decomposition at specific positions of the core?

Many thanks!
Sean

Hi @szhu, welcome to the forum.

Can you upload your workflow so that we can see what’s going on inside?

R-group_decomposition_debug.knwf (16.6 KB)

Here it is. Thanks.

Can you say more about the result you’re trying to achieve?
I’m not sure I see where the issue is.

I’m trying to remove R group that only contains [H]