R (Interactive) on Windows

Hi,

Do I need additional nodes and software (e.g. R) to be able to run the R (Interactive) nodes from the Knime Labs on Windows 7? And how do I configure R under the Preferences menu in order to be able to use them?

Thanks!

No, you don't. If you have updated KNIME with the R interactive nodes AND the R Binaries (R 2.15) from our update site, R will be configured and work under Windows; nothing need to be changed in the preferences. Do you see any error?

Hi,

When I try to configure an R Interactive node (e.g. R View (Table)), I get

R cannot be intialized.
Cannot load JRI native library

I just did a clean install of the latest Knime (2.8.2) and only added the Interactive R Statistics Intergation nodes (2.8.2), and the R Statistics Integration (Windows Binaries) (2.15.2), which then gives the result mentioned above.

I also noted that this configuration does not give me access to the regular R nodes, I need to install the R Statistics Integration nodes (2.8.0) as well in order for them to show up. This does not fix the problem with the Interactive R nodes though...

Hi,

I just did a fresh install of Knime 2.9, but still can't use the R Interactive nodes, I still get:

ERROR     R View (Table)                     Execute failed: Cannot load JRI native library

Please advice!

Within the KNIME preferences, are you pointing to your own R installation (R3?) or the one you have downloaded from our update site. We also provide a FAQ entry for further details: http://tech.knime.org/faq#q25

Hi,

My R (Labs) preferences look like this:

C:\Program Files (x86)\Knime\plugins\org.knime.ext.r.bin.win32.x86_2.15.2\R-Inst

Hi,

 

first post here on Knime's forums. I was trying the interactive R nodes on 2.6 and was ennoyed by the lack of syntax highlighting in the editor - I upgraded to 2.9 this morning both on windows and linux but still can't get the syntax highlight working. Is there a preference I need to set?

Cheers,

Luca

Gabriel,

Any ideas why this still doesn't work? Again, My R(Labs) preferences are set to use the Knime extensions, not a separate R installation. Still I get the JRI error message:

ERROR   RController   Cannot load JRI native library

Please advice!

Sorry for the hassle, did you follow the steps as described in the faq entry? http://tech.knime.org/faq#q25

The new R integration comes with a completely revised node set that you need to download from our KNIME Labs update site; the category path is KNIME Labs/R (interactive) in the Node Repository.

Hi again,

My read of the FAQ entry is that I sould not have to do anything since I'm using the Windows extensions, which should include the rJava library:

'If you are using the new R (labs) integration released with KNIME 2.8, you must have the rJava library installed. This is, by default, already included with the Windows extensions.'

Or do I really need to perform steps 1 through 5?

Hi,

I gave the R (Interactive) nodes another try in Knime 2.10.1 but without success. According to the 'What is already installed?' list the nodes are installed but I cannot find them among the nodes, they are not under the Knime Labs nodes.

Please advice!

Hi

knime version 3.1

I m trying to execute setup_twitter_auth() function in knime - R source node.

the script executes infinitely, gives no error. 

i m using the same default R preferences .

Can any one help on this?

Thanks

Hi Aditi,

could you make a new thread for this one? It is easier to see the new posts than for the community.

Do you already know about our Twitter extension?

Best regards, Iris