R View now and anti-aliasing

Hello,

Quick question about the “R view node” in KNIME and anti-aliasing, maybe someone has some hints?

There is this age old problem in R, where the default Windows graphical engine used to create images without aliasing. It was fixed (not sure when) in the R studio. Plots (especialy noticable in circles) are looking a OK now:

But in KNIME, still no antialising:

Is there anything I can do to get the same results as in the R studio?

I’m aware the R view node has an option to generate svg output, but it’s tricky to get predictable results, it messes up font sizes and line width: image

Thanks in advance for a reply.

You could try and just use ggsave with svg and see how that does work. Also you could tweak the size and dpi settings in order to increase the image resolution.

2 Likes

@mlauber71 Thanks for the reply. After some trial and error, I came to the same conclusion. Saving files from R to a local folder works good enough as a workaround.

I suspect the R view node in KNIME ignores the graphical settings in R studio and always picks the windows device:

:confused:

KNIME does not use RStudio and does not use these settings. You would have to make them within the R node or at the R View node.

Aaah, I see, I was just looking at the Github page: GitHub - knime/knime-r: KNIME Interactive R Statistics Integration

Kind of interesting. I wonder if there is a way how to force it to use a different driver. :thinking:

Not sure what you mean by driver. With KNIME you can either use the ‘integrated’ version off R on Windows or you use whatever installation and packages you have. I have a collection that might help you to choose.

Concerning your graphic. You might want to tweak the dpi and size settings and the output format (svg).