Random Forest Learner - Column Selection Bug

OS: Windows 10 Enterprise
KNIME Version: 3.7.1
Node: Random Forest Learner (similar behavior found in Gradient Boosted Trees Learner)

Bug Description:
When working with a dataset that contains a column labeled “id”, the node does not allow the “id” column to be excluded while the “Enforce exclusion” option is enabled. When the “id” column is moved to the Excluded columns section, and the “Enforce exclusion” is enabled, the node resets that column to the Include section when you go back to configure node.

Steps to reproduce bug:
[1] Connect a dataset that contains a column labeled “id”.
[2] Attach the data to a Random Forest Learner node.
[3] Configure the Random Forest Learner node to exclude the “id” column, and enable “Enforce exclusion”
[4] Click Apply/Ok to close node’s configuration window.
[5] Open the configuration window of the Random Forest Learner node again, and inspect the excluded columns. The “id” column has been placed into the “Include” section again.

The inverse problem occurs when you attempt to Include the “id” column while Enforcing Inclusion… the “id” column is reset into the Excluded section…

This issue is specific to columns labeled “id”.

Hi there!

I couldn’t reproduce it. Maybe there is some more settings I’m missing in order to get behavior you are getting. Can you create an example workflow and share it?


1 Like

I have enclosed sample data and workflow.

sample_data.xlsx (207.0 KB)
test.knwf (17.4 KB)

Hi there!

tnx. I see. And now I see why I couldn’t reproduce this behavior. It is not related to the column name being “id” rather to the choice of target column. If the first string column in data set is not chosen as Target Column then if you exclude it and enforce exclusion it will be included and if you include it and enforce inclusion it will be excluded. I will test it and check a bit more.

Tnx for reporting this and sharing a workflow.


Thanks for looking into it! Very tricky… :wink:

i think the same issue is with gradient boosted trees learner

Hi there!

Which version are you running? This included multiple nodes (including one you mentioned) but each one should be fixed with newest, 3.7.2 version.


3.7.1 - i’ll check it after update and let you know