(Re)start error after installing Geospatial Analytics Extension: Eclipse related?

KNIME no longer (re)starts after installing Geospatial Analytics Extension for KNIME. Most likely related to Eclipse. Using KNIME 4.7 in old interface.

In order to install the GeoFile Reader via Drag & Drop, I had to install the Geospatial Analytics Extension for KNIME:

A “hard” restart was required, but now KNIME won’t start and throws an error:

An error has occurred. See the log file:
 C:\Program Files\KNIME\KNIME\configuration\1687798422056.log

Checking the log with more than 4000 lines there is a recurring pattern. Every paragraph starts with something similar to:

!ENTRY org.eclipse.equinox.p2.ui.importexport 2 0 2023-06-26 18:53:45.555
!MESSAGE Could not resolve module: org.eclipse.equinox.p2.ui.importexport [517]
   Unresolved requirement: Import-Package: org.eclipse.equinox.internal.p2.ui

and at the deepest level, there are many variations on a theme that all seem to point to an issue with Eclipse, e.g. org.eclipse.equinox.p2.

Even KNIME Core and UI are affected as it appears:

Unresolved requirement: Require-Bundle: org.knime.js.core; bundle-version="[4.0.0,5.0.0)"
  -> Bundle-SymbolicName: org.knime.js.core; bundle-version="4.7.2.v202303211209"; singleton:="true"
	 org.knime.js.core [753]
	   Unresolved requirement: Require-Bundle: org.eclipse.equinox.p2.ui; bundle-version="[2.4.0,3.0.0)"
		 -> Bundle-SymbolicName: org.eclipse.equinox.p2.ui; bundle-version="2.7.500.v20220423-1604"; singleton:="true"
Unresolved requirement: Require-Bundle: org.knime.workbench.explorer.view; bundle-version="[8.0.0,9.0.0)"
  -> Bundle-SymbolicName: org.knime.workbench.explorer.view; bundle-version="8.9.4.v202306091219"; singleton:="true"
	 org.knime.workbench.explorer.view [820]
	   Unresolved requirement: Require-Bundle: org.knime.workbench.ui; bundle-version="[4.0.0,5.0.0)"
		 -> Bundle-SymbolicName: org.knime.workbench.ui; bundle-version="4.7.0.v202301242054"; singleton:="true"

I’ve tried to attach the latest log-files and latest meta-file with .txt extension
metadata.log.txt (477.7 KB)
1687798422056.log (579.7 KB)
1687799685305.log.txt (1.3 KB)
The second log was generated after running “knime -clean” to no further avail.

What to do to resolve this issue? Preferably in a no code/low code fashion.

Thank you for your assistance! :pray:

Hello @qumbaqa ,
you can try to manually remove the installed Geospatial Extension. To do so close KNIME Analytics Platform and go to the installation folder using Windows Explorer. In the installation folder go into the features folder and delete the sdl.harvard.features.geospatial folder

Then go to the plugins folder and delete the two sdl.harvard.geospatial folders

Restart KNIME Analytics Platform, update to the latest version of the KNIME AP and install the Geospatial Extension again. If this fails you need to do a fresh installation of the KNIME Analytics Platform with version 4.7.4 and try to install the extension again.


Hello Tobias,

Thanks for your quick response, this solved the problem! I went straight for a fresh installation and will install new extensions as I go to avoid new clutter. Although I thought I was already on latest version 4.7 (9 June 2023 in splash screen), it was probably the minor version update to 4.7.4 which was required.

Will keep this post as a reference for any future troubleshooting.

Much appreciated!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.