Read OWL Files Problem

I have a problem. I have a folder that contains many owl files. I want to read these files in batch mode, but there is no “Flow Variable” in the “Configuration” option of the “Triple File Reader” node., just like some nodes have a “V” mark next to the “select file”, and there is no option to set the address in the “Flow Variable” option. So is there a way to read multiple owl files?

No problem. Open flow variable tab and use your var in the first combo menu.
I’m attaching a screen capture:


The second var is a boolean var aligned with checkbox in main configuration tab.


I configured this interface, but if I select “Location” or “URL”, clicking “Apply” will report an error.批注 2020-05-11 083822 批注 2020-05-11 083836

This is a problem of many nodes on knime.
In file url insert an url of existing file and after select flow variable to override main setting.

Sorry, because I used the nodes related to “URL” and “flow variables” for the first time, so I don’t quite understand the “In file url insert an url of existing file” part, can you explain it, thank you very much, I use the following node :批注 2020-05-11 143435

A lot of knime nodes have an unexpected behaviour: even if you have setted a fow variable, node check is done using main settings.
So, even if you setted correctly flow variable to cycle over files, you have to compile main form with a path to an existing dummy file (this file will be not read during process because you will set flow variable)


Pay attention! You have to set a Loop End Node after TripleReader Node. If not there will be no loop.


Thank you very much, I solved the problem.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.