Reader nodes can't read ? as missing values, but category

i’ve encountered the problem that reader nodes cant read question marks as missing values in some csv files for the first time, as shown in pic, I used statistics node to explore the data and found No of Missing values shows zero for all columns that contains “?”.

Has anyone encountered the same and how did you resolve it?

Hi @20a523p and welcome to the Knime Community.

Just to make sure I understand, are you passing “?” in the file and expect Knime to read this as missing? That won’t happen. If you have “?” in your file, that means that the cell has a value. Empty cells are interpreted as missing values, and are displayed as “?” by Knime.

For example, see the table I am trying to create:

The 2nd row has “?” as workclass, and the rest of the cells of that column are empty.

And if I look at the executed results of the table, I get this:

Notice how the “?” of the 2nd row is in black, like the values in the age column. The other ones are in red. A red “?” means empty value.

And if I run a Missing value count for both columns in the GroupBy node like this:

I get the expected results that 0 missing value in the age column, and 9 missing values in the workclass column:

Can you show your data to investigate your issue?


Hi Bruno29a,
Thanks for your replies.
It was written as “?” in the file to import. After reading your explanation, I guess that explains well why it presents as string.
Thanks much!!!
Problem solved.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.