Reading a Excel file with the name containing a ":" character

I have a workflow that reads Excel files from a Unix server, they have all the same structure:
13096 - Fuentes de poder - 2024-02-28-current_prices_2024-02-28_21:00:58.xlsx
I have been using the Excel reader node since several months but now it returns an error:
“Execute failed: Task supplying the local file was aborted by exception: java.lang.IllegalArgumentException: NTFS ADS separator (‘:’) in file name is forbidden.”
¿what could have happened?

“java.lang.IllegalArgumentException: NTFS ADS separator (‘:’) in file name is forbidden”

indicates that a file path contains a colon “:” character, which is not permitted in certain file systems or operating system components.

it’s could be that a recent filename change introduced the colon, potentially in the timestamp portion (e.g., “21:00:58”). this could created from a configuration change in the process that generates the files.

you could try,

  • comparing the current filename format with a previous version to pinpoint the colon’s introduction.
  • verify any recent configuration alterations in the file generating procedure.
  • inform administrator, consider remove or replace colons in applicable filenames to ensure compatibility.

possible i’m mistaken, as i’m not an operating system expert, further assistance/verification from specialist in this area is always recommended …

just my 2 cents
rgds

4 Likes

@manugor what would a list files node show the paths to be?

2 Likes

I did that but the colon symbol was there from the start.
Had to change the filename and it worked, but can’t figure why it started failing, since it worked for nearly a year.
thanks anyway

the paths are correct, the Excel reader is what fails

@manugor would have been interesting what the path does say. Also you could try and feed the path to a Python node to try and load it with OpenPyxl to further explore what is happening.

1 Like

regretably, already changed all filenames and the program that load them, so, have no way to do that
Thanks

2 Likes