Reading oracle database tables dynamically - issue with "$" in table names


While reading database tables dynamically works well (using an Oracle Connector and DB Table Selector Node controlled by a flow variable), errors arise for tables, that have a “$” character in the table name. Attempting to read such tables results in the error “java.lang.IllegalArgumentException: Illegal group reference” in the DB Table Selector. Is there a solution to this issue?

Kind regards,
Michael Wakileh

Hi @mwakileh -

Good question. Let me ask internally and see what I can find out.

Hello @mwakileh ,
I just tried to reproduce the problem by either using the name in the Table field or the SQL Statement field and in both cases it worked:

Can you please provide some more info or even a screenshot where and how you enter/use the name in the DB Tabe Selector and attach the full error message from the KNIME log file (Go to View- Open KNIME Log).

1 Like

Hi, the problem arose in a workflow used to explore databases.

The problematic tables do appear in the DB Table Selector Node’s Database Metadata Explorer

Pehaps the issue is related to $_?

I adjusted the workflow to not read the problematic tables. Any clue as to what is causing the error?

Best regards,

Hello tobias.koetter,
The full error message only had 2 lines – these are visible in the name/description of the row filter node in the previously attached jpg. (Unfortunately, I only have read permissions on the Oracle databases, so I am not able to conduct more tests on table name compatibility)
Best regards,

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.