Really weird bug with the POST Request node

#1

Hello everyone,

I have encountered a really really weird bug with the POST Request node. I’m doing a POST request with an XML for the body. Everything is working fine except in the case where a field in the XML contains the value 'OR like this for example:

<common:streetName><![CDATA[CHEMIN DES BOUTONS D'OR]]></common:streetName>

In that case, the post request get an error as a response. If I try for example with:

<common:streetName><![CDATA[CHEMIN DES BOUTONS DOR]]></common:streetName>

It works normally. I also tried with 'OR in Postman and it works normally, so it’s coming from Knime.

Could someone investigate that bug ? I guess it’s not prioritary since it’s quite a special case :smiley:

2 Likes

#2

Hi @samuelVermeulen,
to be able to try it out quickly, it would be nice to know what resource you are sending the request to. Is it public so I can try it out myself? Even better would be if you could share the relevant portion of your workflow (but also only if I can execute it, i.e. have access to the REST endpoint).
Kind regards
Alexander

0 Likes

#3

Thanks for your reply ! No this is a private API and you cannot access it outside of our network and I’m uploading sensitive data so that won’t be possible. Can I give you access to a knime log file or something instead if it can help to pinpoint the problem ? Or maybe I can try to reproduce the problem using public stuff.

0 Likes

#4

Hi,
I just tried it using a local webserver and for me it worked. If you could share the relevant parts of the KNIME log, this would be helpful. Could you also share the error message you are receiving from the server?
Kind regards
Alexander

0 Likes