Regex Extractor - should not act as a filter

Hi
Firstly, love the tool.
while using it i noticed that while it extracts, it also filters rows where there was not match.
This output was contrary to expectations, as the pattern may not exist in all rows.
Ideally where rows have no match it should output a null.

Gavin

1 Like

Hi Gavin,

happy to hear! :slight_smile:

Thanks for the feedback! Actually the ā€œfilteringā€ only happens when you select the output type Rows ā€“ in this case the input row will be removed when there are zero matches, or there will be n duplicates added for one input row there are n matches.

When you select Single Row instead, the output table will always have the same number of rows as the input table. (however, you will not get multiple matches in this case).

Just to clarify: Would you still prefer to have an option a la Rows with null?

Best regards,
Philipp

@Gavin_Attard Any comments on this one?

Hi @qqilihq
Thanks for you patience, itā€™s been a long weekā€¦

Yup, i noticed it happens with Rows .

Indeed, my expectation is that rows with no patches simply come through with null (or using Knime nomenclature - missing value)

1 Like

Ok, thanks for the clarification. Weā€™ll improve this in an upcoming update!

1 Like

Wow, Thank you! Really appreciate this