Removing Values from Column

I currently have a table in KNIME with an identifier column “LDGR” and 5 columns with values. I’m attempting to eliminate the rows in which all columns have a value of 0. I’ve constructed a workflow that creates a new column, summing the total of the 5 columns. I then use a rule-based filter to filter only the rows that have a value greater than 0 in the summed column. In doing this I’m getting an output with the desired table, but when going to the Spec tab, there are still identifier values that I do not want. This is causing an issue later on in my workflow, where I have an excel writer node within a loop. Its writing excel sheets for all 28 rows when I only want to have sheets with values greater than zero. Any help would be greatly appreciated.

2nd Table
Starting Table

I don’t see the output format of your sum column, but this might be one of the cases where you would filter out the value 0.0 instead of 0. You could also try using the row filter and remove values less than some extremely low threshold like .00000001

The format for the dividends column is a Number (double). Also, for my row filter, I used a greater than 0 expression. I just don’t understand why the identifiers with 0 dividends remain in the properties tab, despite them being properly filtered out of the table.

You are missing the close to that Rule. I have never tried to run a rule without ending the statement, so that could be causing the issue. Add this afterwards.


I just tried your solution, but no luck

Can you upload a workflow with some sample data in it?

Sample Workflow.knwf (124.8 KB)
Sure thing

This appears to be working fine on my end. The rows totaling 0.0 in the “Dividends total” column all filtered out as expected and were not included in the Excel file…

I exported it in an executed state. Does it look different?
Sample Workflow.knwf (168.6 KB)

Very interesting. I downloaded your sample workflow and I also got the desired output. Perhaps there is a KNIME bug or something. I might try restarting the program

1 Like

I found it odd that you had a data type of Double and your screenshots showed 0 instead of 0.0… I wonder if throwing a Column Auto Type Cast into your workflow earlier would clear it up. Never seen this one. Definitely seems like a bug to me.

Just tried the Column Auto Type Cast with no success. Perhaps it will fix itself, but thank you so much for your help

1 Like

I am tagging @DanielBog as well so he can see if it is a potential bug. What version of KNIME AP are you running?

My version is 4.5.2. I attempted to restart the program and execute again, unfortunately I’m still l outputting am excel sheet for every value pre-row filtration.

Try dropping “domain calculator” node before the loop. Perhaps the values in the domain aren’t updating.

Attempted your solution first thing this morning and I thought you nailed it. After executing the domain calculator my table specs properly displayed the right number of LDGR_CO variables. However, the excel output still isn’t acting correctly which has my tires spinning. I even threw in a column rename node in an attempt to “refresh” the variables. What I happened to notice after changing the column name is those extraneous companies still have the old identifier of LDGR_CO. I really have no clue how this is possible considering the table that feeds into the loop is correctly containing the desired company list.




Could that be as simple as just deleting the prior excel file instead of overwriting? Since they were all writing to separate tabs in a loop, those prior incorrect tabs would remain in the file even if they were not being written in the corrected workflow.

If not, then also make sure that the Domain Calculator is updating the column that it used for the Group Loop.

KNIME also put in some domain handling changes in which fixed some of my issues in version 4.7.2, so if updating is an option then that could fix the issue.


Sometimes the solution is too simple and overlooked. Thanks so much for your help Mark


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.