Report Concatenate (Table) Misorders Pages

I’m enjoying the new reporting features but I’m having a weird result. I’m generating a series of pages using Group Loop->Component-Model Loop End and then using Report Concatenate to put them all together. Each page represent psychometric data on a educational test - one page per item. The items have an integer question number (1 - 50) and also have names as a string in the format “item-001”.

The final report comes out with page orders:
item-001, item-018, item-019, item-020, item-003, item-021 i.e. only very roughly increasing in number. By changing nodes, checking data at various points etc, the misordering is definitely happening after the loop is completed and hence must be at the Report Concatenate (Table) node.

Is anybody else having this problem?

Hi @njconnolly and welcome to the KNIME forum,

thank you for the positive feedback on the new reporting capabilities…
I tried to reproduce the strange behavior you see, but in my case it worked as expected. Could you share a (minimal) workflow?

Thank you for reporting the issue,

1 Like

The Sorter node before the Group Loop was added while I was trying to work out what was happening (ie ensuring the data was sorted prior).
The Report component generates two single row tables and a graph (all works nicely)
I added a Row Filter just before the Report Concatenate (Table) node to test if it was the issue. If I use that filter to include only, say, the first three rows then it compiles them as: item-001, item-002, item-003 :+1:. If I include the first ten rows then item-010 ends up out of order but otherwise the pages match the row order. Let more rows through and it gets more disordered.

However, the disordering is consistent i.e. for the full set the order of the pages is the same every time. I also tried it with page breaks turned off and the order of the items is still wonky in the same way.

[The other component node is just a front page with a static title]

I tried a simpler dummy data set and a simpler workflow. I also used Report Loop End instead of Report Concatenate (Table) to see if that fixes the issues.

So this smaller data does the same idea. One page per test question (named item-0001, item-0002 etc up to item-0020) with a one line table and a graph.
The pages came out in this order:

I get the same result if I use the Model Loop End and Report Concatenate (Table) method. Pages are compilied as the same order listed above.

I also constructed the same workflow on a different computer (a Mac rather than Windows PC) and exactly the same issue and order of pages.

Note also that if you edit the example workflow from here CO2 Emissions Report – KNIME Community Hub so that instead of the top 3 countries, the report shows the top 10 countries, they will not be presented in numerical order.

Just tried the same thing with the newer example workflow
Works fine as presented when the report shows just the top three countries but if you adjust the setting to show more than that, the page order goes wrong (#1, #2, #11…a whole bunch…,back to #3 etc)

Wow, thanks for the detailed description. I opened a ticket (internal reference AP-21702). I’ll send an update once I know more about the timeline.


I experienced the same problem, even with the new reporting extension of Knime v. 5.2.0

1 Like

Hi @gio_bi & @njconnolly,

we were able to find a fix for the problem. Thanks again for reporting (:smile:) it!
If you want, you can grab a nightly version and test it (but please read the disclaimers and use only a test workspace & data):


Hi @hotzm . I did a very quick test, and the problem (in my particular case) seems to be solved. Tomorrow morning I do some further testing (also to check for any regressions).

1 Like

Good morning @hotzm . Ok for me, thanks

Thanks for trying out the nightly! :slight_smile: You don’t need to wait until the next feature release, since the fix will be part of the 5.2.1 bugfix release.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.