Report Designer error: Object doesn't exist

I am getting the following error when trying to run a report on the server.

However, if I run this report locally there is no problem. If I run a subset (<10K records) I am also not experiencing any issues.

Any suggestions on how to resolve?

Hi @BruceV,

I’m sorry that “the report” looks very different to what you’d expect. Thanks for reporting this issue and sharing your investigations so far.
The generation of BIRT reports has a fixed timeout that I could imagine coming into play here, given your findings. However, this usually only comes up if the report is overly complex and it also surprises me that it would run locally, but not on the server. Is the same data available in both cases? Do you know which KNIME version your are using locally and which version the server is on?

Ideally, we’d look into the server logs to see what exactly caused the error. For that, you are welcomed to reach out to (please reference this forum thread).

It would also be interesting to try to reproduce the issue. If you can cause this issue with a dummy workflow and/or dummy data (e.g. Data Generator), it would be awesome if you could share that workflow.

Kind regards

I usually do heavier pre-processing on granular raw data in KNIME first, then just pass a bunch of smaller prepped data tables over to BIRT geared toward my reporting / visualization goals.



Is there any option in data to report node which can switch off the display of the report on server and simply just allow the download, because i feel the display of over a million rows worth of information is causing the issue.
This may be one of the causes and would like to try if we can just simply download the pdf report and not get to see the information on screen.

Hi @r_jain,

It is possible to disable the report preview in the WebPortal, by setting com.knime.server.webportal.disable_report_preview (in the WebPortal at the very bottom of Administration → Configuration).

However, the root cause may be the report failing to generate. I see you get back to our support and we will follow up there.

Kind regards

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.