Report runs OK first session but then gives error when try to run in next session

I’ve got a simple report with a 3x2 grid containing a few text boxes and 5 images of charts. It ran OK (html and pdf). I closed knime then when when I started another knime session, the report wouldn’t run and gave the error below. I tried resetting and re-executing the "image to report " nodes then restarted knime, but still no joy. Any suggestions welcome (couldn’t find anything similar in the forum)

  • Error happened while running the report.


It’s quite difficult to make a good analysis with this little information.
Maybe you can share some more details with us or even share your workflow. That would enable qualified support from the community.

Thanks for getting back to me. I wasn’t sure how much info to include - I thought it might be something simple I was doing wrong. There are 3 workflows that feed into the final workflow that feeds the report and they’re are a bit convoluted/messy to include. They’ve worked fine for over a year producing my charts - I’ve been using Windows Snipping Tool to cut & paste to a document, but thought I’d try using the reporting tool. It worked fine when first set up but then it didn’t (I made no changes other than start Knime the next day). 4 hours later Snipping Tool looked like the easier option but I don’t like to give up on things I rebuilt the report and it worked again. I closed the Knime session then the report didn’t work when I opened it again. All I’ve done in the workflow chart configuration nodes is ticked the “Generate Image” box, and added “Image to Report” nodes with configuration: “Use custom image scaling” (800x800), PNG format. I could send the (very long) error BIRT report if that’s any help but couldn’t see how to attach a document to this message


My proposal would be to minimise your workflow to the relevant parts.
That would be a (static) table containing the output of your workflow followed by the Image-to-Report node and try whether this small workflow has the same behaviour.
If not I would assume that something changes when you run the workflow the second time.
And again (I know that I’m nasty): Sharing the workflow with us would be a big surplus for a good support from the community.

1 Like

It works again now. Thanks for your support. As you suggested, in a test workflow I cut&paste’d a subset of the main output into a “create table” node then added and configured the various charting nodes from scratch, plus the Image-to-Report nodes. That worked. So I copied the nodes from this test workflow back into the main workflow and it now works. There must have been something I was doing wrong in the main workflow nodes but weird why it would work sometimes. Anyway the outcome is it works so I’m happy/relieved. Thanks again


Great to hear that your issue is now solved.
Maybe it’s possible that you mark this thread as solved.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.