Reports: sum of groups

Taking this reporting example I would like to get the Score (sub)totals for each Zip in this report no discussion if this makes sense, it’s just as an example).

I only need it in the report below the grouped data. So in the attached image (from the above link) under the Score column get a “1.000”.

how can I achieve this?

Hi @kludikovsky,

Does it need to be in BIRT or is it possible to go with the much more straitforward approach which is KNIME Reporting?
If possible, you can aggregate the vlaues and add one row at the end or display the aggregated value in a separate Table View with its own header.


@armingrudd thank you for this hint.
I was somehow bocked inthe “old” days where you could report with group by and sum.
And adding a grouped sum will also allow to use it with BIRT as far as I undertand it.

1 Like

Yes, it’s also possible to do it with BIRT in KNIME. But KNIME Reporting is way more straightforward.
There is a blog post to get started with KNIME Reporting:

1 Like

Hi @armingrudd,

Thanks a lot for this hint. I need to discover this in detail.

Just a hit for improvement of the referenced Knime Report explanation: It took me about 2 hours now to discover how to get to the Node Layout. One of the difficulties I had is that on nodes there is a right click context menu. But the layout is not part of it. The layout button is not active when the component is not selected (which is basically ok). And with the small fonts ans symbols - which can’t be enlarged - its very difficult see any changes in visibility.

Maybe its possible to create a short Video on the Reporting minimal example and link it to the description above as this might help tremendously.

Thank you @kludikovsky for your feedback.

Do you mean accessing component layout editor?
Screenshot 2024-01-19 124248

Thank you @armingrudd, this explaines it.
I had the Classic UI active as this is easier to read for me, and there it’s not in the context menues. I know my problem.

I am used to the dark mode, so the white canvas is a huge problem. Then the gray on white makes it even worse. And the small fonts.

BTW there is bug report open from me, as the fonts seem not to found due to a wrong directory (Classic UI).

Just to give you an impression how I see it I’ve made a picture.

1 Like

We have a ticket for dark mode: NXT-1533


There is an inofficial system property to generally scale (modern) UI which might help you with the small fonts. Add, e.g., -Dorg.knime.ui.zoomfactor=2.0 to your knime.ini.

It’s inofficial because we eventually want to introduce it as a user-setting and remove the system property.


Hello @hornm ,
thanks a lot, this is a real help!!! :+1: :clap:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.