Resetting of workflow nodes during job execution

#1

Hello,

I have/had a workflow running on our knime server, which normally worked fine.

Since the upgrade to the latest server version (KNIME Server 4.8.1, KNIME Server Executor 3.7.1), however, some of the nodes are resettet as soon as the job starts.
In particular GET Request nodes seem to be affected, and since the workflow starts with some of them it aborts almost immediately.
By being resettet I mean, that the compelte settings are set to default and of course without credentials/url ect. the node is not working anymore.
To clarify this, once I deploy the workflow on the server the settings are still all there…

does anybody have had/has a similiar issue?

many thanks in advance

Andreas

0 Likes

#2

Hi @And_Z,

first of all please excuse the inconveniences. We are currently investigating this issue and it looks like a bug. We will keep you posted.

Best,
Marten

1 Like

#3

Hi Marten,

cheers for the fast reply and looking into the problem.

i’ll wait for your analysis then.

best

Andreas

0 Likes

#4

Hello again,

I found another “problem”. Another workflow we have on the server is running rather fine, but once it’s finished the job is not “closed”/deleted. So even clicking on discard in the end will not finish the job.
Therefore the job will still be on the server with a red flag to it.
Is there a way to force the server/workflow to close/finish the job once the workflow was executed?

again many thanks in advance

best

Andreas

0 Likes

#5

Hi Andreas,

Can you please confirm how you try to discard the job? Is this via the WebPortal, or from the client and right-click -> delete?

If from the client, have you checked the “Discard Workflow Job after Execution” option?

Cheers,
Roland

0 Likes

#6

Hi Roland,

I tried to do this via the Webportal.
Most of our colleagues are only using the workflows via the webportal and that’s were the problem occurs.

via the client it’s fine to work with but when people execute them via the portal we always have the remaining jobs, which aren’t finished.

best

Andreas

0 Likes

#7

Hi Andreas,

Just to confirm, your users execute the workflow in the WebPortal until the end? Do they then click the “discard” button on the last page? I.e., is it possible that they don’t actually click through the very last page? (where it only says “Workflow executed successfully”).

Cheers,
Roland

0 Likes

#8

Hi Roland,

that’s for sure something I’ll try to confirm, and/or ask them to do.
Nevertheless is there a way of somehow finishing the workflow automatically after it has been executed (maybe after 10 minutes or so)?

best

Andreas

0 Likes

#9

Hi Andreas,

Unfortunately, there is no way to enforce this - technically, the workflow is not fully executed if your users don’t click through to the last page (there might still be user input happening there, so we can’t consider it “executed”).

If they actually click through to the end, they can either discard the workflow directly, or leave it be so it will be discarded after the specified time (default: 7 days)

Cheers,
Roland

0 Likes

#10

Hi Andreas,

One more small point to add. It is possible to set a global option that defines a maximum job execution time. Perhaps that might help?

com.knime.server.job.max_execution_time<duration with unit, e.g. 60m, 36h, or 2d>

Allows to set a maximum execution time for jobs. If a job is executing longer than this value it will be canceled and eventually discarded (see com.knime.server.job.discard_after_timeout option). The default is unlimited job execution time.
https://docs.knime.com/2018-12/server_admin_guide/index.html

Best,

Jon

1 Like

#11

hi

@RolandBurger
that sounds reasonable and I see the point why it isn’t possible to stopp a WF at a certain step.

@jonfuller
we encountered that already as one of our workflows is taking quite a while (>6h), so I guess that isn’t an option for us here.

anyways I guess i’ll be asking people that they always make sure to discard the job in the end.

will have to become good practice in the end i guess :smiley:

many thanks for your input and advice

best

Andreas

1 Like

#12

@Marten_Pfannenschmidt

just wanted to ask, whether you`ve got any news about the issue.
Is it a bug in the end or maybe something related to our server?

best

Andreas

0 Likes

#13

Hi @And_Z,

it is a bug and we are already working on it. It should be fixed with the upcoming release.

Best,
Marten

0 Likes

#14

Hi @Marten_Pfannenschmidt,

just wanted to ask, whether the problem about the GET request nodes is solved with the 3.7.2 update?

Is there also an update for the server version, which would fix the GET error ?

best

Andreas

0 Likes

#15

Hi @And_Z,

the bug in the GET Request node has been fixed with 3.7.2 (AP-11466: Post Request nodes forgets URL settings on load). We also released the 4.8.2 server version, but to fix your GET request issue it should be sufficient to update the executor.

Best,
Marten

1 Like

#16

Hi @Marten_Pfannenschmidt

our knime server has been updated:

  • Version to be installed:
    • KNIME Server: 4.8.2
    • KNIME Executor: 3.7.2

however i keep getting the same error. i even tried to execute the first GET and the save this executed version on the server, but as soon as I start the workflow in this state on the server the node resets itself again.

Is there anything else that might lead to this error?

best

Andreas

0 Likes