Rest and excel nodes missing

I’m experiencing this problem randomly:

Status: Error: Node “GET Request” not available from extension “KNIME REST Client Extension” (provided by “KNIME GmbH, Konstanz, Germany”; plugin “org.knime.rest” is not installed)
ERROR LoadWorkflowRunnable Status: Error: Node “Excel Reader (XLS)” not available from extension “KNIME Excel Support” (provided by “KNIME AG, Zurich, Switzerland”; plugin “org.knime.ext.poi2” is installed)
THe firlst stime afer updating to 6.1 knime, then i reinstalled knime and after installing python integration the problem reappeared.
I’ don’t know wich is the cause but it’s very annoying since these extensions are two among the one I use more

Thank you for your question. I have a few questions as well in order to be able to narrow down the problem: From which version did you upgrade from? Did you add any extensions other than Python? When these messages show, is there a prompt to download the missing extensions? If yes, what happens when you click it?

Thanks,
Jeany

I updated from the 6 to the 6.1
I did’d istall any other extension
the prompt to install the extension tops to the page before the license agreement (it says that an updated version is already installed).

You could try to start KNIME with the -clean option (just add -clean temporarily to the knime.ini above the -vmargs line).

Hope that removes the issue,
Jeany

I’ve already tried to add this option, but for this particular issue doesn’t work

Hi Cosimotoma,

Here Keep resetting R snippet when restarting knime 3.6.1 you say you resolved the issue of the missing REST and excel nodes by reinstalling KNIME AP. Do you have any further questions?

Thank you,
Jeany

No, I think all the nodes are available now

I’m having this problem with KNIME 3.6.1 on macOS. For no obvious reason the REST nodes and the JSON handling nodes (IO, JSONPath etc) have disappeared. The plug-ins are in there.

This happened to me once before and the only way to fix it was to reinstall KNIME from scratch. I can do that, but it’s not really a solution.