Reverse Location Lookup - can not read coordinate


I have tried to use the Reverse Location Lookup from Nodepit. I have downloaded an exaple flow that works fine, but when I create an input node with the same columns and tries to edit the condiguration of the Reverse Location Lookup node it says it can not find a column that is compatible with the geocoordinatevalue.

I have also taken the data from the exaple flow and exported it to excel through excelwriter node and used that as an input to the Reverse Location Lookup node.

Maybe somebody have an idea if it is a matter of character codes or something? I am in Sweden.

reverse 1
reverse 2

Hi @twe , the input for Reverse Location Lookup (RLL) must be of a geocoordinate type instead of string type.

Use Latitude/Longitude to Coordinate — NodePit to convert your column to the right input type before feeding it to the RLL Node.


Hi @badger101 ,

I tried that but got the message attached.


Your current input type is string. Convert them to Double type first, using this node String To Number – KNIME Community Hub , then feed it to the node I mentioned above.

Thank´s for teaching me the basics I should have figured out @badger101 !

Now I get all the wau to setting the configuration of the ReverselocationLookup node, but I can not execute it, it is grey?

That’s too vague of an info. And without a workflow attached, not much people can do to help you with. Sorry.

Sorry, should have attached. Here is comes.

Malmoe Krime.knwf (33.1 KB)

Okay thanks, I’ve ran it and it seemed that there might be something wrong with RLL node. Tagging @qqilihq for that matter.

The workflow runs fine for me until the Latitude/Longitude to Coordinate node. Where exactly does the issue happen? The Reverse Location Lookup node is not connected - you’ll need to use one of the location sources (local or GeoNames). Might that be the issue?

Ok, location sources, I see that as input to the node but how do one configure that?

I have now added the node Geonames location sorce and regsitred a user and activated it - everything works well. Thnak´s for the support to get here!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.