RGtk2 GUI Package not getting installed

Hi 

I am a relatively new user to KNIME. I have been trying to install the 'gWidgetsRGtk2' package through the R snippet, but it keeps throwing me an error when i try to load it. 

if(require("gWidgetsRGtk2")){
  print("gWidgetsRGtk2 is loaded correctly")
}else{
  print("Trying to install gWidgetsRGtk2")
  install.packages("gWidgets",dependencies=TRUE)

options("guiToolkit"="RGtk2")

I have tried changing the R path in the global preferences, and also tried adding this package directly into the KNIME-R folder.

None of these methods seem to work. Can anyone suggest a way out?

Even I am facing the same issue when I install KNIME in my mac. Any guidance in this regard will be very helpful.

Hi Aaron,

I was able to install and use the package you mention without any special steps.  Can you post the error that you are running into?  Also, what OS & R versions are you using? Finally, can you tell us a bit about your application?  GUI building in R in KNIME sounds a bit unconventional :)

Cheers,

Other Aaron

Hi Other Aaron :),

Can't think of what i might be doing wrong.

I am using Windows 7 enterprise, using KNIME v2.10.0 and R 3.0.1. The error I get is:

Loading required package: gWidgetsRGtk2
Loading required package: RGtk2
Failed with error:  'package 'RGtk2' could not be loaded'
In addition: Warning messages:
1: package 'gWidgetsRGtk2' was built under R version 3.0.3 
2: In library(pkg, character.only = TRUE, logical.return = TRUE, lib.loc = lib.loc) :
  there is no package called 'RGtk2'
Error: Could not install gWidgetsRGtk2

I am researching into various Analytical tools and their functionalities.

Regards,

Aaron

Could you also share the process you followed in installing this package?

 

Regards

Aaron

It looks like the problem is that you are unable to install a dependency (RGtk2).  I would focus on trying to get that to work.  See below for a potetntially useful thread on the topic if you get to the point where it is failing to load the .dll.  I'm not sure what else to suggest as I don't have any expereicnce with Gtk. 

http://r.789695.n4.nabble.com/Require-of-gWidgetsRGtk2-fails-RGtk2-dll-can-t-be-found-but-it-s-there-td3588037.html

 

Hey,

I was able to load the package RGtk2. Now I am able to bring up the GUI window.

Aaron