Running Batch - change workspace

Hi,

Having problems when experimenting running batches using a test workflow:

  1. Reads a csv
  2. Selects one column
  3. Exports to a csv
    So a pretty simple workflow.

The incoming csv has this address: knime://LOCAL/FILE.csv

When I run the batch I get the error:
WARN main Node Can’t access ‘knime://LOCAL/FILE.csv’. (File not found: C:\Users\adnivara\knime-workspace\FILE.csv.)

I have changed the location of the workspace in the KNIME application to my F:\ drive. The workflow in question, as well as all files, live in that workspace. When I run the workflow in the application it runs fine.

The batch works if I put the entire file path instead of using LOCAL. However, there are reasons why I want to keep it as LOCAL.

It appears that the batch is using the first workspace I had when I installed KNIME. How do I change this workspace location to my F:\ drive when I run the batch?

Thanks

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.