Running Knime Workflow using batch

Hello everyone,

Im new in the Knime community and I would very much appreciate if you could help me.

I want to use a batch file to run my workflow on Knime.
Slight problem, I’m also a beginner on batch.

I tried to create a batch program but it doesn’t work and I don’t know how to fix it. here is the program :

@echo off

rem Set the path to your KNIME installation
set KNIME_PATH=C:\Users\xxxxxx\Knime\knime_4.3.2

rem Prompt the user to enter the path to the KNIME executable
set KNIME_EXECUTABLE=C:\Users\xxxxxx\Knime\knime_4.3.2\knime.exe

rem Prompt the user to enter the path to the workflow file
set WORKFLOW_PATH=C:\Users\xxxxxx\knime-workspace\Test Batch

rem Launch KNIME and execute the workflow
“%KNIME_EXECUTABLE%” -nosplash -application org.knime.product.KNIME_BATCH_APPLICATION -workflowFile “%WORKFLOW_PATH%”


Ps : Knime is not added to my system path and I can’t add it because i don’t have administrators’ rights

Thank you for your answers.

Hi @Debutant_657 , I just came across this post from June 6th, so I’m hoping you already solved it! Anyway, welcome to the KNIME community!

Quick thing first generally it is better to say what results you see, or what error you get, rather than simply “it doesn’t work”. There are any number of reasons why something might not work and so for people to assist without taking up lots of their time, you need to give them as many clues as possible about where to look. This may well be one of the reasons that nobody responded previously.

That said, one thing I noticed is that you used the parameter -workflowFile instead of -workflowDir

From the FAQ, I can see that -workflowFile is for running a workflow that has been exported to a zip file, whereas you are trying to run a workflow folder contained within your workspace, so you should be using -workflowDir instead.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.