S3 connection says : check your access key id/secret key, while boto3 uses the same credentials to get bucket list

Cannot connect to S3 via connection node using default credential provider chain


Could you help us better troubleshoot with answering a few questions:

  1. Has this ever worked with connecting to S3?
  2. If you attempt to use access key ID and secret key, instead of the “default credential chain” does this allow you to connect?
  3. Are you attempting to access S3 from boto3 on the same machine as accessing S3 from Knime? I am curious if there are any firewall rules that may be restricting connections from certain locations?


Thanks for helping.

  1. Yes it did, but not with this credential.
  2. Yes, copy pasted the same manually, did not connect.
  3. Yes, was successful with boto3.


I guess you got this error message while clicking the “Test connection” button in the Amazon authentication node? Does the S3 Connector node work? Maybe the log knows more (KNIME > View > Open KNIME log and then scroll down).

Did you use the default credentials provider chain in boto or did you use an access and secret key to connect?

Hello Sascha,
Thanks for helping.

Yes it was while testing and the log had:
KNIME-Worker-2322-Amazon S3 Connector (Labs) 11:226:428 : : Node : Amazon S3 Connector (Labs) : 11:226:428 : Execute failed: Please check your Access Key ID / Secret Key.
org.knime.core.node.InvalidSettingsException: Please check your Access Key ID / Secret Key.
at org.knime.cloud.aws.filehandling.s3.node.S3ConnectorNodeModel.testFileSystemConnection(S3ConnectorNodeModel.java:140)
at org.knime.cloud.aws.filehandling.s3.node.S3ConnectorNodeModel.execute(S3ConnectorNodeModel.java:128)
at org.knime.core.node.NodeModel.executeModel(NodeModel.java:576)
at org.knime.core.node.Node.invokeFullyNodeModelExecute(Node.java:1236)
at org.knime.core.node.Node.execute(Node.java:1016)
at org.knime.core.node.workflow.NativeNodeContainer.performExecuteNode(NativeNodeContainer.java:558)
at org.knime.core.node.exec.LocalNodeExecutionJob.mainExecute(LocalNodeExecutionJob.java:95)
at org.knime.core.node.workflow.NodeExecutionJob.internalRun(NodeExecutionJob.java:201)
at org.knime.core.node.workflow.NodeExecutionJob.run(NodeExecutionJob.java:117)
at org.knime.core.util.ThreadUtils$RunnableWithContextImpl.runWithContext(ThreadUtils.java:334)
at org.knime.core.util.ThreadUtils$RunnableWithContext.run(ThreadUtils.java:210)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at org.knime.core.util.ThreadPool$MyFuture.run(ThreadPool.java:123)
at org.knime.core.util.ThreadPool$Worker.run(ThreadPool.java:246)

Via Boto3 in python, it took the default credentials.

Did not go that route. Found credentials that worked and used it manually instead of default chain. So its okay if unresolved.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.