save as bug

Hi everyone.

I am encountering an odd bug running KNIME 5.2.0 on a Mac.
Occasionally, when I ‘save as’ an existing workflow under a new name strange things happen. I cannot create new nodes or changes comments. I can still change the configuration of existing nodes, tho. What’s worse, even though the workflow is correctly renamed, any changes I made prior to ‘save as’ have disappeared when I restart KNIME.
One more detail: a telltale sign for the bug is that the save icon is not greyed out after ‘save as’ as it usually is when the save worked correctly.

Thanks for your help.

1 Like

Hey @TobiasOX,

This may be unrelated, but I would first try to make sure your mac OS is on the latest update as Oracle has mentioned that Sonoma 14.4 can cause Java to bug out and break. Also, I would make sure you are on the latest version of Knime v5.2.3.

On a high level, it looks like it could be related to the workspace? I would try creating a fresh local workspace and try working on it to see if you still encounter the same issue.

If you still run into issues, if you could share any logs that would be helpful!

(As a last resort, doing a fresh install of KNIME may fix the issue you are encountering)



That seems to have solved it. Thanks.
Sorry for wasting your time. I thought I did have everything updated.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.