SDF Stripper to SDF writer not rendering all compound structures

Hello Everyone!!

I have KNIME wrflw where I use the SDF stripper node to clean up my output file, however, once I save the file using SDF writer many of the molecule structures do not show up and instead I get an error. If I do not use SDF stripper the structures are correctly displayed but I get all the columns that I do not want.

Thank you so much for all the help!



Can’t you just write out the SDF file with the SDF Writer node without all columns you don’t want, by putting them in the Exclude section?

The SDF Stripper doesn’t seem to work though, it has no effect on my SDF file whatsoever.

Good luck/Evert

Thanks for your help.
Unfortunately, I cannot see the columns that I deleted throughout the knime wrflw in the SDF write.

But you didn’t want any columns…?

Thanks so following up on this.
I filter out and resort columns in the KNIME wrflw, but the SDF writer does not show those filtered out columns, however, they still show up in the final SDF output file if I do not use SDF stripper.
My issue with using the SDF stripper before SDF writer is that several compound structures can longer be rendered.

What do the problematic molecules have in common?

The error is on line 4. Line 4 of a molecule entry in an SD (or mol) file, is the counts line. This line is made up of twelve fixed-length fields - the first eleven are three characters long, and the last six characters long.
The first two fields are the most critical, and give the number of atoms and bonds described in the compound.

What processing are you doing that might affect this line?

Can you share your workflow here?

I recently discovered the SDF Stripper node when I was investigating a similar issue with columns showing up in the SDF even though I deselect them in the workflow (either using the SDF reader node filter, using a column filter node, or deselecting them in the SDF writer node). It turns out the SD block of the SDF gets passed through the workflow unchanged as a single cell, and then gets written to the SDF where it’s interpreted as consisting of several columns. Using the SDF Stripper solved my problem, but I didn’t get the same error that you are.


Thanks for your help!
I think my problem is converting the SDF molecule structure through the SDF stripper and writing it back using SDF writer. Somehow some structures can not be rendered back in the SDF writer…

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.