Send an email

Hello all,
I feel like a dumb… I do not find the way to send an email via knime.
I just tried through the send email node and it doesn’t work…
I use an SFR email (I’ve also tried my gmail) and doesn’t work for me.
If someone has already mastered to setp up this node I would really appreciate help.

KNIME_project.knwf (4.3 KB)

Hi @crnico,

what is the error message you get?
From just a general look it seems fine like you do it :slight_smile:

Does your mail service has an smtp service?
Ist STARTTLS insead of SSL correct?
*e.g. could it be that you need port 587 insead of 465? (in case of gmail and STARTTLS?)

For gmail

SSL needed: yes
TLS needed: yes(if availible)
Authentification required: yes
Port for SSL: 465
Port for TLS/STARTTLS: 587

1 Like

Hi AnotherFraudUser,

I think my mail service has an smtp service (since I can find smtp information for sfr on internet)

When I tried STARTTLS with port 587 or SSL with 465 I get :
ERROR Send Email 0:1 Execute failed: Error while communicating with the smtp server: javax.mail.MessagingException: Can’t send command to SMTP host;
nested exception is: PKIX path building failed: unable to find valid certification path to requested target

I don’t really understand this message to be honest with you/

I’ve also tried with the gmail parameters you mentionned I get this message :
ERROR Send Email 0:1 Execute failed: Error while communicating with the smtp server: javax.mail.AuthenticationFailedException

Finally I managed to make it works…
I had to activate on my gmail account the paramater “allow access to the applications less secured” an now it’s working.
Thanks a lot AnotherFraudUser



Do you have any idea of how to find my enterprise smtp host and port?
We’re working with outlook with exchange email but I’ve no idea of how to find it.

Hi @crnico,

in case you use outlook365 you could try:
SMTP Host:
SMTP Port: 587
SSL Protocol: OFF
TLS Protocol: ON
SMTP Username: (your Office365 username)
SMTP Password: (your Office365 password)

However in our company this is disabled - and the only possibility is to get the local admin to give you an technical smtp proxy


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.