Send Email node not working after upgrade to 4.6.0

Hello,

I have a workflow that uses the Send Email node to send an email from my Gmail account. It was working well until I upgraded to Knime 4.6.0.
Now I get the following error message:
javax.net.ssl.SSLHandshakeException: No appropriate protocol (protocol is disabled or cipher suites are inappropriate).
Do you know how to solve? Apart from potentially downgrading to previous version of Knime…

Thanks,
Fede

Hey @fedetoffano93 :wave:t2: ,

Some of us were experimenting the same issue as you mentioned.
I can suggest you a workaround to solve it that it works for me:

In the Send Email node configuration go to > (Mail Host (SMTP)) and use port 587/STARTTLS. See screenshot below :eyes: :point_down:t2:

Lmk if it works also for you!

3 Likes

Awesome!!! It did solve!!!

1 Like

To get a better understanding, why did it work?
My previous settings were port 465 and connection security SSL.

We’re not exactly sure yet, although there has been some discussion internally about this. It seems to be a combination of the recent KNIME update including Java 17, and some changes made on Google’s side.

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.