"Send to Power BI" node issue

Hello Knime forum,

i’m using “Send to Power BI” node in Knime 4.1.1. in Win10 to overwrite rows in an existing dataset in my personal PowerBI workspace.
Authentication and workspace are ok (status = Authenticated and workspace = default).

In the dataset section i’ve selected the option “Overwrite rows” for existing Dataset and i can see the existing dataset name “test_powerBI3”,
but then i’m not able to select the table name “iris” inside this dataset (wich is the only table present): in the dropdown list i can only see the message “Authenticate to select table” and no more options (see img)…

I’ve tried all the 3 authentication options, close/open/reset workflow and restart Knime but the behaviour is the same…

Am i doing something wrong?..

Thank you for any feedback


Hi Ema,

I have not seen this problem yet and I cannot reproduce it. Do you see any error or warnings in the KNIME log? (View -> Open KNIME Log).

Are the tables shown for other datasets?

Additionally, it would be awesome if you could help to debug this issue by reproducing the REST API calls that KNIME issues to Power BI with the following steps:

Finding out the id of the dataset:

Get the tables of the dataset:

Could you paste the relevant sections of both responses? (Please remove all personal information)



Hi Benjamin,

thank you for your quick feedback, i try to answer your questions.

- Do you see any error or warnings in the KNIME log? (View -> Open KNIME Log).
Sorry, i’m not an expert of Knime log, so i can’t understand it, but i attach it here (see attach1.txt eg. only last session, i just opened the workflow and tried to setup the node).
Node raises a message when i try to close configuration “Invalid settings: table must not be empty” due to missing selection in the dropbpx for table selection…

- Are the tables shown for other datasets?
No, it seems to be a problem for all my datasets: I have 3 different dataset and i can’t see any table…
I don’t know if it can be useful… but i first generate a report in PowerBI Desktop and then i published it in PowerBI.

- finding datasets and tables
ok i can see the datasets ids, then i tried to execute the test for tables with those ids, but i have an error message (see attach2.txt)

attach2_retrive_tables.txt (2.1 KB) attach1_Knime_log.txt (5.1 KB)

Hope it can be useful, Thank you for your help and for any suggestion


… i’ve found this:

seems that API doesn’t work for datasets created in PowerBI Desktop… :cry:
So i think i have to upload the dataset from Knime and then re-build all the reports in PowerBI (online) from scratches…
not sure i can use PowerBI Desktop to build a first report and then use Knime to update data… is that true? :sob:

Hi Ema,

I think you are right. If you create a report with Power BI Desktop it will link it to the Dataset and I see no way how to change the dataset (manually because Power BI does not seem to allow this, or using the API because it is no “Push” dataset). You can create a report in Power BI Desktop based on a dataset that you already uploaded using KNIME (Use a Power BI dataset as the data source in Power BI Desktop).

You could ask in the Power BI forum if they are planning to support changing the type of a dataset or changing the dataset of a report.

Still, I want to thank you for your report. I created a ticket in our system to filter out datasets in the node dialog that are not “Push” datasets and notify the user if there are datasets that cannot be used because of this.



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.