Sending email directly through knime.

I created a workflow in which I have an output from a graph in the image format. Now I have to send this image further to an email address. How can I do this?

Also can someone tell me which input file is used for a Send Email node. I tried to execute it by going through some the forum solutions but I couldn’t solve it.

Thank you.

Graph Project.knwf (10.8 KB)

Hi @SupportOfficer2,

welcome to the KNIME Forum, take a look at this workflow in the hub, it looks like it addresses your usecase of sending an image via email:



Hi there @SupportOfficer2,

Send Email node optionally needs a red (flow variable) connection as input. Flow variables are pretty useful in KNIME so I suggest following video to learn more about them:

If you’ll still have trouble connecting Image Writer (Port) to Send Email node and/or successfully sending scatter plot image as attachment drop us a message here and someone will help.

Welcome to Community!



Thank you @gab1one,

I went through the workflow you have attached above. It is prompting an error that Knime is not able to execute the Python source node. Do I need to have Python software installed on my system?

Can anyone suggest which SMTP host and port shall I use while using the Send Email node.
Also which connection shall I use?

Depends on your mail provider
e. g. for gmail:

Enter as the server address.
In the Port field, enter one of the following numbers:
If you’re using SSL, enter 465.
If you’re using TLS, enter 587.

For authentication, enter your full G Suite or Gmail address ( and password. Make sure to sign in to the account before you use it with the device or app.


I used the following details in the Send Email node:
SMTP Port: 587 (for TLS)
SMTP Port: 465 (for SSL)
SMTP Host:

But I still cannot execute the node. It is still showing some error (Refer image 2).
I also gave access to third party on my gmail account.
Can someone explain me where I am going wrong?

Thank You.

1 Like

Hi @SupportOfficer2,

you have to enable the access in your account first see:

As well make sure you use the correct user/password credentials (you did not enable need authentication and passwort is missing in the screenshot)


Thank You @AnotherFraudUser,
Finally I could do it.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.