Seqan incompatibility with Generic Workflow Nodes 1.0.0

#1

Hi Seqan Team,

I have currently installed the Generic Workflow Nodes in its latest version 1.0.0 from the Community Contributions Update Site for KNIME 4.0. Unfortunately, I am not able to install the latest version of the Seqan NgsToolbox Nodes from the same update site as they depend on Generic Workflow Nodes in version range [0.8.100,1.0.0).

Software being installed: Generic Workflow Nodes for KNIME 1.0.0.v201907091326 (com.genericworkflownodes.knime.feature.feature.group 1.0.0.v201907091326)
 Software being installed: NgsToolbox 0.1.0.201906201319 (de.seqan.ngs_toolbox.feature.feature.group 0.1.0.201906201319)
 Only one of the following can be installed at once: 
  GenericKnimeNodes 1.0.0.v201906282022 (com.genericworkflownodes.knime 1.0.0.v201906282022)
  GenericKnimeNodes 0.8.100.v201906191249 (com.genericworkflownodes.knime 0.8.100.v201906191249)
 Cannot satisfy dependency:
  From: Generic Workflow Nodes for KNIME 1.0.0.v201907091326 (com.genericworkflownodes.knime.feature.feature.group 1.0.0.v201907091326)
  To: com.genericworkflownodes.knime [1.0.0.v201906282022]
 Cannot satisfy dependency:
  From: Generic Workflow Nodes for KNIME: NgsToolbox 0.1.0.201906201319 (de.seqan.ngs_toolbox 0.1.0.201906201319)
  To: bundle com.genericworkflownodes.knime [0.8.100,1.0.0)
 Cannot satisfy dependency:
  From: NgsToolbox 0.1.0.201906201319 (de.seqan.ngs_toolbox.feature.feature.group 0.1.0.201906201319)
  To: de.seqan.ngs_toolbox [0.1.0.201906201319]

Are there any plans to get rid of the version limitation and make the Seqan NgsToolbox Nodes compatible with the latest version of the Generic Workflow Nodes. Otherwise, latest at the point were new nodes dependent on Generic Workflow Nodes with version range [1.0.0,2.0.0), we have an either or situation.

Best regards,
Daniel

0 Likes

OpenMS incompatibility with Generic Workflow Nodes 1.0.0