SFTP Upload issue using Azure Blob : Session is down


I encounter an issue using SFTP Upload in Knime with Azure Blob Service.

The first step of setting up the Authentication is working. And the second fails with an error message : Session is down. This was working previously 1rst February.

The upload is working with another SFTP server eg: Linux based.

Here is the logs messages from Knime :

2023-02-14 11:12:06,692 : ERROR : KNIME-Worker-13-Upload (legacy) 3:7539 :  : Node : Upload (legacy) : 3:7539 : Execute failed: session is down
com.jcraft.jsch.JSchException: session is down
	at com.jcraft.jsch.Channel.sendChannelOpen(Channel.java:762)
	at com.jcraft.jsch.Channel.connect(Channel.java:151)
	at com.jcraft.jsch.Channel.connect(Channel.java:145)
	at org.knime.base.filehandling.remote.files.SFTPRemoteFile.openChannel(SFTPRemoteFile.java:620)
	at org.knime.base.filehandling.remote.files.SFTPRemoteFile.lastModified(SFTPRemoteFile.java:436)
	at org.knime.base.filehandling.upload2.UploadNodeModel.upload(UploadNodeModel.java:249)
	at org.knime.base.filehandling.upload2.UploadNodeModel.execute(UploadNodeModel.java:154)
	at org.knime.core.node.NodeModel.executeModel(NodeModel.java:549)
	at org.knime.core.node.Node.invokeFullyNodeModelExecute(Node.java:1267)
	at org.knime.core.node.Node.execute(Node.java:1041)
	at org.knime.core.node.workflow.NativeNodeContainer.performExecuteNode(NativeNodeContainer.java:595)
	at org.knime.core.node.exec.LocalNodeExecutionJob.mainExecute(LocalNodeExecutionJob.java:98)
	at org.knime.core.node.workflow.NodeExecutionJob.internalRun(NodeExecutionJob.java:201)
	at org.knime.core.node.workflow.NodeExecutionJob.run(NodeExecutionJob.java:117)
	at org.knime.core.util.ThreadUtils$RunnableWithContextImpl.runWithContext(ThreadUtils.java:367)
	at org.knime.core.util.ThreadUtils$RunnableWithContext.run(ThreadUtils.java:221)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at org.knime.core.util.ThreadPool$MyFuture.run(ThreadPool.java:123)
	at org.knime.core.util.ThreadPool$Worker.run(ThreadPool.java:246)

Any of you encounter the same issue working with SFTP upload with Azure Blob Service ?

I feel like Azure has uploaded its API or Security practices making Knime Upload disconnect.

Any help would be greatly appreciated.


Hi @geoffreym,

glad to have you on board in our forum :slight_smile:
I’m afraid this error isn’t known to me and may require or be caused by changes on Azure side.

However, what you could try from KNIME’s side is updating, in this case the nodes. It looks like you’re currently using the Upload (legacy) node.
Checkout the newer Microsoft Authentication and Azure Blob Storage Connector nodes in our File Handling Guide.

These offer a connection that the Transfer Files node can use.


Kind regards

1 Like

Hi @marvin.kickuth, thank you for your response.

I have tried what you suggested me to do from KNIME’s side.

The Microsoft Authentification node works fine with the SAS token.
However, the authentifications to the Azure Blob Storage Connector node and Azure Data Lake Storage have failed, below are the screenshots of these errors :

I have tried to do the same thing with Azure Storage Explorer client and it worked just fine.

Any idea why?


Hi @geoffreym,

Azure has a very fine-grained permission system. Calling the same resource in different ways may require different access rights. This is also true should you authenticate in different ways. I’m afraid I don’t know the exact permissions required/in use in these scenarios, but the error strongly suggests that the access rights granted in the SAS token don’t cover the required permissions for the requests being made.

Kind regards

1 Like

Hi @marvin.kickuth ,

Thanks for you support.

We finally gave up the opportunity to login with SAS Token.

We went to the Account Name/Key method of authentication with “Microsoft Authentication” Node, which succeed.

Kind regards.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.