Sharepoint Connector: Overwriting of files on Sharepoint failes, Sharepoint always refers to initial version of file

Hi all,

I recently discovered a bug - at least from what I can see - when I want to write an Excel file to Sharepoint via the Sharepoint Connector. Not sure whether the problem lies with KNIME or Sharepoint, but: Every time I try to overwrite a file that I have written to Sharepoint before, it would not do that but rather show me the very first version of the file I wrote to Sharepoint. I can also delete the file on Sharepoint before and execute the workflow but it still shows me the very first file of the same name that I wrote to Sharepoint (although it was deleted). Very weird. Has somebody experienced something similar and knows where the problem is buried?

Thanks a lot in advance!



Hi @tstolle94

thanks for reporting this issue. Could you clarify if I understood that correctly. You have some data and write it to a folder as an Excel file within in Sharepoint and at some point you overwrite this file with new data? After the overwrite if you view this file within Sharepoint it still has the initial data? Which KNIME Version are you using?

Best regards

Edit: Potentially you could share a workflow which could reproduce the issue in which we just need to replace the MicrosoftAuthentication node and the path for the file

Hi @laaaarsi,

yes, that is correct. And even if I delete the initial file with the initial data first before executing the workflow again (so technically not overwriting the initial file), then execute the workflow and expect the new data, it still shows me the initial data from the initial file. So it seems like there is data of one file name saved somewhere in the background as soon as it has been written once, maybe in a cache or something, which prevents the workflow from overwriting it, I dont know.
I am using Version 4.6.5 as I cannot upgrade as our server cannot work yet with a higher version.




I tried to reproduce by configuring one Excel node and created an Excel file and afterwards I changed the data and have overwritten the file and it worked totally fine for me. Are you executing this workflow locally or on the server? If you use your credentials in the MS Authentication node, configure the Sharepoint Online Connector node and adapt the path in the Excel Writer node (same path for both writer) and execute the Writer nodes step by step does this reproduce the issue on your side?

sharepoint_test.knwf (17.3 KB)

Now it works. But I am actually not using the Excel writer node, but rather the “XLS Formatter (Apply)” node as I am first appending two sheets within the workflow area, then format them both and then write them to Sharepoint with the XLS Formatter (Apply) node. I also discovered one more difference between the two. When I write my files with the usual Excel Writer Node, then I do not have to “check in” the file on Sharepoint, but writing them with the XLS Formatter (Apply) node, I do have to do that. Since those XLS Formatter nodes are community nodes (if I am correct), there is probably not much that you can do on your side, am I correct?

Thanks a lot already!



You are correct these are community nodes. I haven’t worked with those nodes before to be honest but if I understood the node description of the node correctly it only applies the format to an existing xlsx file? Maybe someone from Continental can elaborate on that, you could ask here


Alright, will do that, thanks!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.