Sharepoint Online Connector - Timeout Error

Hello everyone,

I have a workflow for connecting to Sharepoint Online, it works very well locally, but on server it does not.

First, i was unable to run MS Authentication on server, but it seemed working fine after setting the token storage option to “storing token in node” instead of “storing in-memory”

But the problem is still persist with Sharepoint Online Connector node:
I tried to extend the timeout period, but no luck.

Any help would be truly appreciated.

Hi @JayR

Can you let us know what version of AP, Server and Executor you are using and on what OS?

Are you aware of any firewalls and/or proxy being used in this setup?

Also, would you be able to show the Sharepoint Online Connector node’s Settings/Advanced tabs (redacted, if necessary)?

Hi @Dora_Oravecz,
Thanks for your prompt response!

Server: 4.13.1
Executor: 4.5.1

Sharepoint Online node settings:


Hi @JayR while this is likely not the root cause, we always recommend users to keep their Server and Executor versions compatible. In your case for version 4.13.1 Server the most compatible executor would be 4.4.x, but since downgrading would not benefit you, upgrading your Server to 4.14.x would be what I’d suggest first.

You can find more information about product compatibility below:

Can I ask again if you are aware of any firewalls and/or proxy being used in this setup?

Hi @Dora_Oravecz ,
I just re-checked server version, and it seems it was upgraded recently to 4.14.1

Regarding your question about proxy, I’m not sure if i get you well, but if you mean whether we’re using proxy within our organization, then yes.

Below is a snapshot of Network Connections setup in KNIME preferences


Hi @JayR thank you for the details.

Can you check if you incorporate another MS Authentication node directly before the Excel Writer node, you still have end up with the timeout error?

Hi @Dora_Oravecz ,

Sorry, I didn’t get your point here.

But no worries, I managed to figure it out, we realized that our MS account requires MFA, accordingly, it will end up with Timeout error. So, we moved to another approach which is establishing app to app connection in aim to avoid MFA.

I found out that MS Authentication node doesn’t provide “Client/Application Secret Authentication” option for Executor versions less than 4.7 :c

Tried “Get SharePoint Rest Connection” node as an alternative, but it seems AF Utility Nodes Extension is not supported on Server? am I right?

Any advice would be appreciated.

Hi @JayR glad to hear you located the source of the timeout error. So even when you have the AF Utility Nodes extension installed on your executor this “missing extension” error occurs?

Hi @Dora_Oravecz , yes it still occurs.

Hi @Dora_Oravecz , i think since it’s a community extension it will not be installed on Server. So don’t bother with this problem, we’re planning to upgrade our KNIME Server in aim to be able to use “Client/Application Secret Authentication” option in MS Authentication node, it seems this’s the only possible option for our case.

Appreciate your time & support,

1 Like

I have the same exacto problem. Are anybody from Knime side working on that? This issue makes the SharePoint Online connector almost useless…

Hi @bermq do you mean your Sharepoint Online Connector also results in a timeout error when executed via your KNIME Server? Is your MS account also utilizing MFA?

Can you let us know what is your current KNIME Analytics Platform version?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.