ShellExec command exited non-zero exit value (when installing Extensions)

For the L4-TP course, I try to install the necessary extensions “Redfield BERT Nodes” and “Redfield NLP Nodes”.

I tried the installation in my company network, with active proxy settings (that allowed me to install other extensions) and also from home without any VPN or proxy connections. I always get this error.

When researching, I found the “long path limitations” note in the General Information section of the Extension.

And I checked my registry if this is set. Yes, it is.

Any other ideas why I get this error?
In addition, I also tried to run KNIME as an Administrator to rule out permission problems. Same result.

Hi Mathias @pfmd86,

thanks for doing the troubleshoot with long paths already.
Could you gather create_env.err and create_env.out as describe here please?

Additionally, which KNIME version?


1 Like

Okay, now I feel stupid. I just triggered the installation again to make sure it had the most recent entries in the log file, and it worked. So, it might be proxy-related.
I’m on KNIME 5.2.3, and I could not find a create_env.err nor a create_env.out in the log folder.


Glad it worked and thx for the follow-up!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.