Silicos-it 3D-d-Chem installation failed

Hi everyone,

I installed the 3D-e-Chem nodes but I could’nt intall the Silicos-it.
The Knime node installer returns this error: “Cannot complete the install because some dependencies are not satisfiable nl.esciencecenter.e3dchem.knime.silicosit.feature.feature.group [1.1.3.v201906270957] cannot be installed in this environment because its filter is not applicable.”

Any idea from it come from and how to solve it?

Many thanks.

Hugues

Hi Hugues,

I just installed the 3D-e-Chem extension without a problem and it has the Silicos-it nodes in it. This is the update site I used and I am running MacOS. http://update.knime.com/community-contributions/trusted/4.1

Could you please check that you have the right update site in your list of update sites? You can also try a fresh installation of KNIME to see if there is some dependency problem/conflicts in your current installation.

Let me know if this helps.

Best,
Temesgen

Hi Hugues,

Which operation system are you using?

The Silicos-it nodes only on Linux and MacOS.
The Windows binaries are not available, as I was unable to compile them for Windows from the source code at http://silicos-it.be.s3-website-eu-west-1.amazonaws.com/software/software.html .
So installing the 3D-e-Chem nodes on Windows, will exclude the Silicos IT nodes.

Best,
Stefan Verhoeven

2 Likes

Hi Temesgen and Sfefan,

Thank you very much for your replies.
I indeed use Windows 10 as OS, and based on Temesgen reply I suspected that it was the source of my problem.

I will try to run knime with 3D-e-Chem node on a Linux machine.

Best,
Hugues

1 Like