Simple File Reader and batch mode

Hello Knime Team,

I am trying to use the new node Simple File Reader. It works fine with the knime open, but when I try to use in batch mode appears:

# A fatal error has been detected by the Java Runtime Environment:
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x000000006a326014, pid=28956, tid=0x00000000000047c4

If I switch to file reader node, this doesn’t occur. But I want to use the Simple File Reader, as this node is more efficient and faster.

Hi @vanessa and welcome to the forum.

I’m not able to reproduce this problem in AP 4.2.1. Are you making sure to save the workflow and close KNIME entirely before batch execution, and that you don’t have the file you’re trying to read still open in any other software?

Hi @vanessa - I think this may have been solved in today’s 4.2.1 hotfix release - can you confirm?


Hi @ScottF
I’ve tried to reproduce the error in the simplest workflow possible, I’m attaching it to this reply.
It seems to throw an error whenever the Simple File Reader node is within a metanode that also receives variables through a port. Using this sample workflow, if I replace the Simple reader for a regular reader, or if I just remove the variable link between the metanodes it runs without issue.
I’ve tried it with the 4.2.1 version in different machines, with different input files

simpleReader.knwf (13.8 KB)

Hi @phin01 -

Strange. I’m not able to reproduce your error either in KNIME AP or via batch mode using the workflow you provided (using 4.2.1 in Win10). Out of curiosity, what OS are you using?

Hi @ScottF
Interesting question. The machines I’ve originally checked at work all run Win10 1809, I then tried it on my personal computer (Win10 1903) and it threw the same error.
But… then I also checked it on an old Ubuntu 18 laptop and it ran without problems.

Are you running a newer Win10 build? I also noticed my Win10 machines are all running Java 8 while the Ubuntu one is running Java 11… Do you suppose that could also be related, or just a coincidence? I’m fairly sure I can switch Java versions at my work machines, but Win versions unfortunately not.

still same problem. :frowning: Current Java from Windows doesn’t work for me

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.