SMTP Configuration for Knime Server (Send Email)

I urgently need your help, I’m setting up a flow where it always shows the error “Execute failed: Could not connect to SMTP host: smtp.google.com, port: 587, try adjusting the smtp timeout settings” I’m using the corporate email from my company that is google domain and even so I can’t, I will leave attached print of the flow.

I would also like to validate with you, if my flow is correct I wanted to send it in excel format if possible, can you help me?

image



Dashboard Bodegas.knwf (133.3 KB)

Hi @Gabriel2020 ,

You will most likely need to enable the following setting “allow insecure /less secure apps”:

Also, you may want to just check with your company’s internal team to make sure you are using the correct configuration for the smtp settings.

Thanks,
Zack

4 Likes

Hello @Gabriel2020
Also taking into account what @ztrubow suggests (that’s a very important step), you should use the smtp.gmail.com SMTP Host. That is the correct smtp configuration for a google account.

This is an example of a send email node that I use daily with a Google account (sorry I can’t show the email)

Please give it a try and let us know if it works.

Cheers

2 Likes

Eventually you want to talk to your local IT, too.

For example when using our company wide VPN I cannot connect.to external SMTP servers like Google or my own.

Just my 0.02