Snowflake Connection Error with Okta SSO

Both KNIME and Snowflake are somewhat new to my company. I am the first person at my company to look to connect to Snowflake via KNIME. I would really appreciate help to figure out setting up this connection - or at least helping me frame the questions so my IT staff can help me with this.

I have pieced together notes from the KNIME and Snowflake websites. I can do this successfully on my ‘home’ computer to a personal Snowflake account. However using my work laptop and connecting to my company’s Snowflake account is causing me trouble - almost certainly related to my company’s security.

My attempt at the jdbc url looks like this:


When I try this, I am getting this error:

ERROR DB Connector 0:1 Execute failed: JDBC driver encountered communication error. Message: Exception encountered for HTTP request: No trusted certificate found.

Other points in case they are helpful:

  • Even with the &authenticator parameter in the url, KNIME is demanding a username and password.
  • I get this same error even if I remove the &authenticator= part of the url.

Hello @kevweath,

and welcome to KNIME Community!

Guess you found this topic? User managed to connect to Snowflake with Okta adding &authentication=xxxx to the Snowflake connection string.

Additionally your error message seems like traffic network issue. There are many topics about it (and one FAQ question) and I suggest you search around forum a bit. Here is one that seems most similar to yours after a quick search:

And last but not least there is plan to have a dedicated Snowflake connector in future. Stay tuned!


Hi @kevweath -

It sounds like some certificates need to be added to your keystore? Tobias talks about that in a MySQL context in this thread:

I also did a little digging and found this link on the Snowflake forum, which may be of some use to your IT folks:

I will also tag @tobias.koetter here to see if he has any specific suggestions for you about connecting to Snowflake in this case.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.