KNIME Analytics Platform 4.2 Update - Cannot connect to extensions repository

Up until KNIME 4.2, I have had no problem reaching the extensions repository upon update. Now, I cannot access it. Based on the error message, there is a missing or failed certificate somewhere. Please help. I cannot use KNIME until this is fixed.

KNIME Community Extensions (Trusted)
https://update.knime.com/community-contributions/trusted/4.2

Here is the error message:

Some sites could not be found. See the error log for more detail.
Unable to read repository at https://update.knime.com/community-contributions/trusted/4.2/content.xml.
sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
Unable to read repository at https://update.knime.com/partner/4.2/content.xml.
sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
Unable to read repository at https://update.knime.com/analytics-platform/4.2/content.xml.
sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
Unable to read repository at https://update.knime.com/community-contributions/4.2/content.xml.
sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

4 Likes

Hi,

I’m having the same issue. Is there a way to fix this?

Thanks

1 Like

The message suggests that you are behind a proxy that manipulates that encrypted SSL connections and injects an unknown certificate. Also local virus scanner can lead to the same problem. It’s not an issue with our update site.

1 Like

I am checking the firewall proxies with our company IT department. It is taking a while to hear back.

The curious part is injection of an unknown certificate. I suspect that’s not the actual error. The request is likely being blocked by proxy. Still, I have not had this problem with any previous version of KNIME. It only appeared when I installed 4.2.0. Best guess at this time is the list of extension api URLs (APIs) need to be added to an approved security list.

1 Like

Hi mbergman

were you able to resolve this issue?

HI @Br1jesh
Here’s a solve… https://docs.knime.com/latest/analytics_platform_installation_guide/index.html#_adding_local_update_sites
Download the .zip file of extensions (https://update.knime.org/analytics-platform/UpdateSite_latest42.zip)
Follow the instructions on the above link to create a local site. Once you have created a local site, go to Help --> Install New Software --> Choose the local site you just created. It should look like this:

You can also create a local site for the community extensions with the zip file found on here: https://www.knime.com/community

Hope this helps!

2 Likes

HI @Br1jesh, @Snowy,

Needed to add domain *.knime.com to SSL bypass. Then, I had access to all of the KNIME extensions.

Hope this helps.

–Mark

1 Like

I also had this issue after upgrading to 4.2. At a client site, I am behind a Proxy.
I originally downgraded to an older version in order to continue work.
However, I gave it another crack, and found the following worked for me…

Go to File > Preferences > Install/Update > Available Software Sites
Change the Location of all the repositories, replacing “https” with “http”

11 Likes

That works. Nice workaround!

–Mark

Although, I guess this doesn’t really get to the root of the problem. I still had the same issue when trying to connect to data on Azure etc.
I was able to resolve by manually entering my clients proxy server into the following

3 Likes

Has anyone else had luck in addressing this issue definitively?

My VPN was recently updated and now I am getting this error. Previously, adding *.knime.com to the Proxy bypass had resolved it.

Hello @TardisPilot,

so you updated VPN and changed nothing on KNIME side? Do you have any proxy configuration in KNIME preferences?

Br,
Ivan

Hey @ipazin, correct. The VPN software changed and now I’m getting the PKIX error. I have another machine that has our old VPN software and it works just fine. I do not currently have a proxy config other than the *.knime.com Proxy bypass in my KNIME prefs as that was sufficient previously.

Networking is not my strong suite, so what would you recommend that I look for to reconfigure KNIME correctly?

2 Likes

Hello @TardisPilot,

I will stay away from any suggestions as I’m not network expert :slight_smile:

While waiting for one you can use local update sites to install extensions:

Br,
Ivan

2 Likes

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.