Snowflake "Reserved" names...

Would it be possible to add an option to SQL nodes to always quote column names, not only column names with spaces?

Snowflake allows column names to be reserved names/operators, but when the SQL is compiled in KNIME and sent to Snowflake via JDBC, these reserved names are not quoted and results in syntax errors.

DB Column rename also does not work - I tried. :slight_smile:

You ca use not just quotes but ] [ square brackets…

Snowflake uses double quotes for column names, so that’s what I would need.

Hi EvanB,
have you tried the new database framework that we released with KNIME 4.0? The new framework quotes all identifier e.g. column names and tables names. You can also specify the quote characters via the Advanced tab of the DB Connector node. For more details about the advanced option see this section of the database documentation.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.