[solved] R Scripting - library import problem



I simply forgot to restart Rserve() ....



Hi everyone,


I am struggling with KNIME and the integration of R code via the R scripting plugin. In particular I am using the "R snippet (2:1)" and the problem is that I cannot load my library.

I properly installed the library as I can run my the script on the local R installation (linux machine).

In KNIME it does not work. When I run the empty node (or just some dummy R code) no errors occur. I actually found some threads where people had the same problem but they seemed not up-to-date, because I do not have a i.e. "R binary tab option" in the Snippet node. However, I did change the KNIME -> Preference -> "Location of R on your computer".

Since I do not have admin rights on our machine I installed the packages to a custom dir. I added therefore export R_LIBS=mypath:$R_LIBS to my .bashrc. Does this might cause the error?


Thanks in advance,

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.