[SOLVED] Reading .mdb fails on 'Invalid JDBC URL'

Hi all,

I am pretty new to KNIME and this forum, excuses up front if I'm posting in the wrong section of the forum.

I am trying to read a .mdb file into KNIME with a Database Reader node. Using Google I found a topic in this forum that described how it should work (https://tech.knime.org/forum/knime-general/no-connection-to-ms-access-database ). This helped me add the UCanAccess driver to KNIME, but following that I get errors about the provided URL.

Here is the exact URL as it is in my URL Dialog box:  jdbc:ucanaccess://C:\Users\A089847\Z Local Files\Stage\Data\Test\Lacam data\Derived data\Data40.mdb;showSchema=true

And here is the exact error message from the KNIME console: ERROR Database Reader 0:7 Execute failed: Invalid JDBC URL in settings: jdbc:ucanaccess://C:\Users\A089847\Z Local Files\Stage\Data\Test\Lacam data\Derived data\Data40.mdb;showSchema=true

I have tried a lot of different combinations of slashes, backslashes, %20 instead of space characters. They all produce the same error.

I also downloaded and tried the example workflow provided in the topic I linked earlier. The Database Connector node works correctly in that workflow, so the DB Driver is registered and working fine. The only difference I can spot is that the Database Connector takes its URL from a flow variable, which does NOT work when I copy it into the URL dialog box of a Database Reader/Connector (tried both) node!? What am I missing here?

Thanks in advance, J



@Tobias, thanks for your response. I made it work after using the same flow variable setup in my last piece of text.


have you tryed copy the mdb file to a path without spaces? Maybe the driver does not support spaces in the file path. It also seems that the driver uses / also for windows paths e.g. jdbc:ucanaccess://c:/data/pippo.mdb

Have you considered to ask the question in the UcanAccess forum since this seems to be a driver related problem.