[SOLVED] Strange behaviour Impala Connector (legacy) after moving Workspace

impala
#1

Hi there,

recently I had to change the location of my workspace from drive C:\Users\MyName\knime-workspace to F:\Knime_Workspace .
So I exported all Workflows, created a new folder on F:, switched within the preferences the location of the workspace folder and imported the workflows again.

Now the problem is, that I cannot connect to my impala database anymore. Even if I create a new workflow the Impala Connector does not work! The Error Message is: Execute failed: Could not create connection to database: Maybe invalid user name and/or password

But when I switch back to C:\Users\MyName\knime-workspace it works.

Is this a bug?

Andres

0 Likes

#2

Hi there Andreas,

did you maybe register a Cloudera driver in your old workspace or changed any other preference needed for connecting to Impala? Preferences are workspace related so creating a new workspace means you have a default preferences applied on it.

You can export preferences from old workspace and import them into new one. Go File --> Export Preferences… and then File --> Import Preferences…

Hope this helps,
Ivan

0 Likes

#3

Thank you so much! I didn’t know the fact with the preferences. So after importing the Prefs into the new Workspace everything works fine!

0 Likes

#4

Hi there,

glad to hear that. Also there is a new Impala connector together with new Database Integration nodes :wink:

Br,
Ivan

0 Likes

#5

Yeah I know, but I do not get them to run :frowning:

I always recaive the error: “Execute failed: Could not open client transport with JDBC Uri: jdbc:hive2:// […]”

In the legacy node the "Cloudera Impala Driver (com.cloudera.impala.jdbc41.Driver, version: 2.5) is used.
In the “new” node: Apache Hive JDBC Driver (for Impala) [ID: impalaHive] is selected.

Maybe there is the issue, but I don’t know…

0 Likes

#6

Hi Andres,
the new and the legacy framework are two separate plugins that use their own libraries. Therefore in addition to the legacy framework you need to register the Cloudera Impala driver also for the new database framework. For more information about this see the new database documentation.
Bye
Tobias

0 Likes

#7

@ActionAndi

I see you changed the topic title to set this topic to solved, thank you for this!

You can also choose set the topic to solved by selecting one of the answers to be the solution. For this you need to use the three dots below the topic and than check the solved button :slight_smile:

0 Likes

#8

Hi Tobias,
unfortunately I do not get the drivers to work.

In my opinion the old way of inserting the drivers was easier… Just select the corresponding folders and thats it! Now I have to add some settings I do know at the beginning… e.g. the URL template and some names…
I still receive the error: “Execute failed: Selected JDBC driver does not support given JDBC url.”
How can I find out, what JDBC url was generated?

0 Likes

#9

Hi Andres,
we needed the flexibility that the approach with the user defined URL templates provides us. We will be working on the UI to make it easier for you in the future to provide the correct values.

When you register the driver please make sure to select impala as database type.

the correct URL template for the Cloudera Impala driver is

jdbc:impala://<host>:<port>/[database]

In the Impala Connector node dialog make sure that you have selected your driver. During execution , and [database] are replaced with the values from the node dialog

The <> brackets indicate mandatory values whereas indicates an optional value.

To see the generated JDBC URL you can enable the JDBC logging via the Advanced tab of the Impala Connector node

Once enabled all JDBC operations are logged into the KNIME log file which you can open via View->Open KNIME log

Bye
Tobias

1 Like

#10

Hi Tobias,

thanks a lot! The hint with the URL template did it!

Bye
Andreas

1 Like