Spotfire Information Link Reader

#1

I installed Spotfire nodes in KNIME and wanted to read data from Spotfire Information Links.
I have spotfire server url in the form: “https://spotfire.companyname.com/spotfire
and information link url in the form: “/folder1/folder2/folder3/infolinkname”

But when i configure this information in the node and click Apply/OK, then it showed error: “failed to apply settings: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target”.

After this I removed the proxy configuration in KNIME and tried the above steps again. This time it logged “WARN KNIMEApplication$4 Potential deadlock in AWT Event Queue detected. Full thread dump will follow debug output.” and after 10 minutes an error dialog popped up with message “Invalid settings: connection timed out”.

I am neither able to read info links nor spotfire library data.

Has anyone faced this already? I am totally stuck with this issue. Any help will be appreciated.

0 Likes

#2

Hi @Ranbir-Sinha -

It sounds like you might be missing a CA certificate in the AP keystore. Is that something the IT folks at your company can help with? If you are feeling adventurous, you could try the following:

0 Likes

#3

Hi Scott,

Thanks for your message.

I am able to proceed after adding the certificate in keystore, but now i get a message “401 unauthorized access” while trying to read an info link.

I investigated the issue further and found that the TIBCO Spotfire Nodes are not using the HTTP “Negotiate” authorization scheme. The spotfire server expects authorization through negotiate but I can’t find a way to use that scheme.

When I load the url “[https://spotfire.companyname.com/spotfire/wp/Services/DataAccessDataConnectionService65.ashx?getInfoFor=infolinkpath) in Google Chrome, it automatically performs the Negotiate authorization and thus it is successful in browser.

I tried to set the property “http.auth.preference=” to “Negotiate” and “SPNEGO” in JRE, but it did not work.

Do you have a workaround for this issue?

Regards
Ranbir Sinha

0 Likes