SQL Express 2012 connection issue-Please Help

I have loaded latest KNIME from website & am trying to link to SQL Express 2012 database on my local machine with windows authentication.

I have read through database connection issues on community pages  of your website & still not successful.

I have loaded onto 2 different computers (standalone) and I seem to have hit a wall


  1. Downloaded latest SQL driver to see that it is compatible with  version of Java (8).
  2. Latest iteration of loggging in to database is:
  3. jdbc:sqlserver://;database =RTV_ReporterPro_SPM;integratedsecurity=true
  4. I have tried variations o=n the theme:

jdbc:sqlserver://localhost:1433;database =RTV_ReporterPro_SPM;integratedsecurity=true

jdbc:sqlserver://localhost/database =RTV_ReporterPro_SPM

jdbc:sqlserver://localhost:1433/database =RTV_ReporterPro_SPM;


  1. I have my SQL database up and running.
  2. This is the error I get:
  3. ERROR Database Reader      0:1        Execute failed: com.microsoft.sqlserver.jdbc.SQLServerException: The TCP/IP connection to the host, port 1433 has failed. Error: "Connection refused: connect. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall.".
  4. I have norton 360 on my computer- I have Disabled firewall.
  5. I also have allowed exceptionds to firewall for Ports 1433 & 14345
  6. I have also modified my knime.ini file with this path:

-Djava.library.path=C:\Program Files\Microsoft JDBC Driver 4.0 for SQL Server\sqljdbc_4.0\enu

  1. I also downloaded     ntlmauth.dll and put it in the above directory along with sqljdbc_auth.dll and sqljdbc4.jar
  2. I have also found computer name and PING'd it ( or do I need to ping the specific port? The link in the community post was followed as best I could)


Can you please help me. I have looked through posts and tried all the suggestions that I thought pertained to my issue.

Kind regards,


I'm not an expert with SQL Server but the error message is pretty clear: there is no database service listening on port 1433. Either it's the wrong port, the database is not running, there is simply no listener configured in the database.