SSH-Connection: Failed to send channel request


I am trying to connect to my NAS via the SSH-Connection node. Using PuTTy (64-bit, Win10) everything works fine. But in Knime I receive the error:

Do you have an idea what I am doing wrong?

These Settings I am using:

Best regards,

Hi @ActionAndi,

does the same public key and port work with putty (or another ssh client)?

you can search for “JSch failed to send channel request” for more suggestions (the lib behind the ssh node)

From e.g. this discussion:
"Check if SFTP server is started and running.

I had encountered the same issue - I was not able to open SFTP channel to my server, but I could connect with WinSCP. It took me some time to notice that WinSCP would fallback to SCP hence confusing me. Starting the server solved this issue."

it sounds like you should test if ssh is actually enabled on your NAS :thinking:

If that does not work, try to disabled sftp/ftp access for your user and then re-enable (e.g. maybe create a new user instead of admin beforehand)

Else it might help to check the KNIME log for thr detailed error description in KNIME


also i just noticed - how is your authentification set up? you have a keyfile referenced in your node but not authentification by keyfile enabled?

1 Like


I found it! Many thanks!
On my Diskstation SSH was enabled, but SFTP wasn’t.

The Node “SSH Connection” needs a SFTP connection and not a SSH connection. Maybe the developers can add a hint to the node description.



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.