SSH Connector - Empty Table

Hello fellow KNIME User,
I have the following issue: I want to gather data (txt, csv, etc…) from another server via SSH Connector.
Behind that node I put a File Reder (in parallel also CSV Reader for testing). In the File Reader, SSH is selected and I am able to run both nodes without any error.
The problem is, that my output always is an empty table.
My txt or csv sheets are really simple for testing reasons, yet the table is always empty.

I also tried the “Transer File” Node after the SSH Connector.
It actually transfers the file to the specified location, e.g. my desktop, but again, the file is empty.

I tried all kinds of setting in all the named nodes but the result is always the same.
Could it be that there is some kind of encryption setting somewhere else, that will “delelte” the information within the files?

Maybe someone can help me!

Hi @EngiP3 , could it be that the file that you are reading is actually empty? :slight_smile:

@bruno29a Well, if only :D. No all testing files are filled. Not much, only like two to three lines.
There is no compiling error. Also the file readers are showing no preview which is already strange.
In addition, I can track the activities on the server that I want to gather the files from.
That means I can see when KNIME is “downloading” the files. So no issue there.
But the files are just empty.

That’s a weird behaviour indeed @EngiP3 . Can you try to write to a file on the ssh server from Knime, and then try to download/read the file from Knime?


Yes, I did that and the writing part does work and it contains data. If I want to download it again though it’s empty.

But we actually solved the issue. A colleague who set up the share on that server, changed the program from SSH-Bitvise to Solarwind. And now I can successfully read the data of the file :slight_smile:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.