Standardizer Node Error

Using a .sdf input file, I have tried to run the Standadizer node under ‘Manipulations’, however I get an error message “Atoms coordinates are not defined”. So I tried the RDKit generate coordinates (both 2D and 3D), as well as the generate 2D coordinates from Indigo, and all still result in the same error message. What else should I try?

Thanks
Clinton

Hi @Clinton,

Can you post the sd file here?

Hi. This is one of the sdf files I am using. However, the same thing happens with any of my files.
It won’t let me add .sdf files for some reason, so I have just zipped it into a folder.

Inactives.zip (22.0 KB)

Thanks again
Clinton

What standardization options are you choosing to apply?

I tried the standardize-neutralize-zwitterions and standardize-stereo-from-coordinates together, and separately and all give me the error message.

That’s a little strange. When I try it everything seems to work fine.
What version of KNIME are you using? And what operating system?

Maybe a KNIME team member will see this at some point.

Hi. I’m using version 4.1.2 on Windows Server 2012. What would be the best way to contact a team member?

Thanks.

Hi Clinton.

Thanks for your question! I was unable to reproduce the problem so far. Could yo maybe share a small workflow here where the problem happens?

Best,
Jeany

1 Like

I tried to generate the error again, however it seems to have resolved itself. I haven’t made any changes to the flow and simply restarted and it has fixed the problem.

Thanks again.

1 Like