Strange behavior of 3D-e-Chem Pharmacophore from Molecule Node

Hi all,

Does anyone have some tips on how to get started using the 3D-e-Chem Pharmacophore from Molecule node to generate pharmacophore models?

After installing the extension (I’m using KNIME 4.1.1) I did a quick test with aspirin and ibuprofen, and, while the node executes and gives a pharmacophore output column, none of the relevant features are being detected. For example, I don’t get any aromatic rings, hydrogen bond acceptors, or hydrogen bond donors.

This does not change if 3D coordinates are explicitly specified.
This does not change if hydrogens are implicit.
When hydrogens are explicit I get the following error:

Execute failed: Unknown "null" type, should be one of AROM,HYBH,NEGC,HACC,HYBL,HDON,POSC,EXCL,LIPO

Sulfur-containing molecules (I tried with cysteine) end up being marked as having an aromatic ring when none exists.

I haven’t been able to locate any documentation about the requirements for this node.

Any insight would be greatly appreciated.

Hi @elsamuel,

I am not an expert in using the extension, but mybe @sverhoeven has some ideas or could point you to a documentation / tutorial / example workflows? that would be nice :slight_smile:

Best,
Martyna

HI,

The Pharmacophore from molecule is meant to read a molecule as if the atoms are pharmacophoric features, like atoms of nitrogen (N) element are read as if they where positive charge pharmacophoric features at the location of the atom. It does not generate a pharmacohpore from a molecule, for this you can use the Silicos-it align-it node.

Example workflows can be found at https://github.com/3D-e-Chem/knime-pharmacophore/tree/master/examples

Hope this helps,
Stefan

2 Likes

Hi @sverhoeven, thanks for the reply, your explanation is helpful.

I tried installing the Silicos-it-align-it node, but I think I’ve run into some compatibility issues.

When I choose the options to show only the latest versions, and only software that’s applicable to my target environment, I get versions 1.0.1.v201707211232 and 1.0.0.v201704211116.

In both cases, I get the error message:

[…] requires ‘bundle org.knime.workbench.core [3.3.0,4.0.0)’ but it could not be found

Perhaps unsurprisingly, turning off the target environment compatibility requirement and trying to install to the latest version gets me the error message:

nl.esciencecenter.e3dchem.knime.silicosit.feature.feature.group [1.1.3.v201906270957] cannot be installed in this environment because its filter is not applicable

Can you confirm whether there is a version of the Silicos-it-align-it node that is compatible with KNIME 4.1.1 on Windows?

Ah sorry did not know you where using Windows, Silicos IT nodes are not available on that Operation System, see Silicos-it 3D-d-Chem installation failed

Thanks. I’ll see if I can get this up and running on a Linux VM.