String manipulation in REST API workflow

#1

Hi.

I have a REST API workflow that contains several String Manipulation nodes. When I test workflow within KNIME Analytics platform, I have no warnings. But when I run workflow through API call with same input JSON, I have several warnings in response like that:

‘nodeMessages’: [{‘node’: ‘String Manipulation 0:273:241’,
‘messageType’: ‘WARNING’,
‘message’: ‘Unable to copy required class path files’},

and it looks like the workflow is not working properly because the output JSON contains the default values, not the calculated values.

what could be the problem?

0 Likes

#2

Hi @Sergey_Bazov,

welcome to the forum! Here you can always find help from our large and lively community.

Could you please elaborate on the Server (and Executor) versions that you use? There can be a forward-incompatibility issue, if for example you use a local Analytics platform 3.7.2 to create a workflow and then try to run it on a Server of 4.7 family, that uses Analytics Platform 3.6 as an executor.

Best regards,
Mischa

1 Like

#3

You’re right… Server version is 4.7.3, and Analytic platform version is 3.7.2…
So what can I do with this issue? I rent server on AWS

0 Likes

#4

Hi Sergey,

the optimal option would be to upgrade the Server. If this is not feasible, then you have to downgrade the local AP installation on your machine to 3.6.X, try to open an existing workflow from 3.7.2 in this local 3.6.X version, modify it to start working, re-save and then upload that to the server. Note that ideally the X in the local version should be lower or equal than the bugfix version (third digit) used as executor on the server.

KNIME maintains backward compatibility, i.e. we take care that you can open old workflows in a new version. But we can not guarantee forward compatibility, i.e. open new-version workflows in an old version.

Best regards,
Mischa.

2 Likes

#5

Thank you for feedback. I will try.

0 Likes

#6

I downgraded the Analytic Platform version to 3.6.2 (max version 3.6.X, available for download), opened and saved under a new name minimal project with a problem. And tried to run the API. The problem remained.

1 Like

#7

Hi.
On your advice we have studied the server logs. After studying the server logs, we assumed that the problem is the lack of space for temporary directories
(…Caused by: java.io.IOException: Cannot create temporary directory ‘/tmp/knime_javasnippet37185’.)
We cleared the logs to make space on server. After that, the problem was solved. No warnings, and workflow works.

Thank you :slight_smile:

2 Likes